Rails エラー [The dependency tzinfo-data (>=0) will be …]

プログラミング
スポンサーリンク

Rails でアプリ開発学習をしていますが、下記のエラーが毎回出て気にはなっていました。

動作に問題があるわけでもないのでしばらく放置をしていましたが、原因を調べてみました。

環境

OS:Windows10

ブラウザ:Google Chrome

IDE:Cloud9

原因

gemファイル内「tzinfo-data」オプション

「platforms: [:mingw, :mswin, :x64_mingw, :jruby]」

が起因でエラーが出ていました。

「platforms: [:mingw, :mswin, :x64_mingw, :jruby]」 を削除し、「budle updete」を実行したら解消ができました。

tzinfo-data作者様のコメントによると

Windows環境でタイムゾーンデータを取得することを目的に使用するとのことです。

platformsオプションを削除して不具合は今のところ出ていませんので、しばらくこの状態で様子を見たいと思います。

コメント

タイトルとURLをコピーしました