Railsエラー「ERROR: Failed to build gem native extension」

プログラミング
スポンサーリンク

Windows10 pro を使用しています。

ローカル環境でRails開発を行いたいと思い設定をしました。

ここまでの大まかな流れは

 1.VS Code をインストール

 2.VS Code の拡張機能「Ruby」「Ruby on Rails」を導入

 3.「rubyinstaller-devkit-2.6.6-1-x64」をインストール

その後再起動をし、 「gem install rails」を実行するとタイトルのエラーが出てしまいました。。

下記はその時のエラー画面です。

かなり悩みました。

「rubyinstaller-devkit-2.6.6-1-x64」 を入れなおそうと思い、実行ファイルを実行すると「MSYS2」のセットアップ画面からうまく先に進まなくなるため一度「MSYS2」を消してみようと思いました。

その後現在の最新版だった 「rubyinstaller-devkit-2.7.1-1-x64」をダウンロードし、再インストールし再起動。

再起動後、 「gem install rails」 を実行

結果、、、

インストールできました!!!

「rails new」でテスト。

テストアプリも作成されました。

原因はよくわかりませんが、結果論として「MSYS2」が何らかの理由で邪魔をしていたようです。

これで何とか動くようになりましたので、これからはローカル環境でRailsを触っていきたいと思います。

コメント

タイトルとURLをコピーしました